Difference between revisions of "2016-10-17: bwUniCluster Maintenance"

From bwHPC Wiki
Jump to: navigation, search
(Change of Software Defaults)
(Software Modules which will be REMOVED)
Line 27: Line 27:
   
 
== Software Modules which will be REMOVED ==
 
== Software Modules which will be REMOVED ==
  +
  +
* Very old Intel compiler (and related) modules currently available to all bwUniCluster users (/opt/bwhpc/common/modulefiles):
  +
** compiler/intel/12.1
  +
** compiler/intel/13.1
  +
** numlib/mkl/10.3.12
  +
** numlib/mkl/11.0.5
  +
** mpi/impi/4.1.0-gnu-4.4
  +
** mpi/impi/4.1.0-gnu-4.5
  +
** mpi/impi/4.1.0-intel-12.1
  +
** mpi/impi/4.1.1-gnu-4.4
  +
** mpi/impi/4.1.1-gnu-4.7
  +
** mpi/impi/4.1.1-intel-13.1
  +
** devel/itac/8.1.1
  +
** devel/itac/8.1.2
  +
** '''All dependent modules and binaries will stop working thereafter. So rebuild your modules and/or binaries with newer versions of the Intel compiler.'''
   
 
* Software currently available to all bwUniCluster users (/opt/bwhpc/common/modulefiles):
 
* Software currently available to all bwUniCluster users (/opt/bwhpc/common/modulefiles):

Revision as of 14:09, 10 October 2016

The bwUniCluster system will be unavailable between October 17, 2016 and October 21, 2016 for scheduled maintenance.

We strongly recommend to recompile all your binaries after the maintenance due to operational system as well as software and libraries upgrade. This does also apply to binaries that may have been built as add-ons for existing software modules, e.g. private packages for R and Octave, Matlab MEX files, etc.

The batch system queues will be closed starting a couple of days before the maintenance window and will then be cleared. Data on the parallel file systems will remain intact.


1 Operational System Upgrade

  • Upgrade from Red Hat Enterprise Linux Server release 6.8 (Santiago) to Red Hat Enterprise Linux Server release 7.2 (Maipo)

2 Software Module Updates

2.1 Change of Software Defaults

  • chem/turbomole/7.0 -> chem/turbomole/7.1
  • chem/tmolex/4.1 -> chem/tmolex/4.2
  • math/R/3.1.2 -> math/R/3.2.1 (or newer)

3 Software Modules which will be REMOVED

  • Very old Intel compiler (and related) modules currently available to all bwUniCluster users (/opt/bwhpc/common/modulefiles):
    • compiler/intel/12.1
    • compiler/intel/13.1
    • numlib/mkl/10.3.12
    • numlib/mkl/11.0.5
    • mpi/impi/4.1.0-gnu-4.4
    • mpi/impi/4.1.0-gnu-4.5
    • mpi/impi/4.1.0-intel-12.1
    • mpi/impi/4.1.1-gnu-4.4
    • mpi/impi/4.1.1-gnu-4.7
    • mpi/impi/4.1.1-intel-13.1
    • devel/itac/8.1.1
    • devel/itac/8.1.2
    • All dependent modules and binaries will stop working thereafter. So rebuild your modules and/or binaries with newer versions of the Intel compiler.
  • Software currently available to all bwUniCluster users (/opt/bwhpc/common/modulefiles):
    • chem/turbomole/6.5
    • chem/turbomole/6.6
    • chem/tmolex/4.0
    • chem/molden/5.2.1
    • math/R/3.0.2
  • Software currently ONLY available to users from Freiburg (/opt/bwhpc/fr/modulefiles):
    • chem/lammps/5Sep2014_linux
    • chem/lammps/5Sep2014_mkl
    • cns/nest/2.2.2-python-2.7.6_cns
    • cns/nest/2.8.0-python-2.7.6_cns
    • devel/cmake/3.0.1
    • devel/python/2.7.6_cns

|